Skip to content

Commit

Permalink
dev-haskell/reflex: bump to 0.8.0.0
Browse files Browse the repository at this point in the history
There is an [issue upstream][1] to allow newer base. A [separate
issue][2] has been opened to bump `profunctors` and `template-haskell`

[1]: diagrams/diagrams-core#112
[2]: https://github.com/diagrams/diagrams-core/issues/449

Signed-off-by: Wolfgang E. Sanyer <WolfgangESanyer@gmail.com>
  • Loading branch information
ezzieyguywuf committed Jan 14, 2021
1 parent b261fc5 commit 6e3f138
Show file tree
Hide file tree
Showing 3 changed files with 102 additions and 3 deletions.
1 change: 1 addition & 0 deletions dev-haskell/reflex/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST reflex-0.6.3.tar.gz 145821 BLAKE2B 720a106815dee15ee0d2e02de2ab6b2e06e40eaafd01993ea7b9424d40e43c416b833648511bd7b7fb1cef3532bacd624d5dc619c36d83f8e4308cc975282763 SHA512 cd3114a90cb3bd028f7ba947743eb6dece68eb0857f42912abea3da77fd8b12af3499a15458828ff0186f771354f18efca7c30e19717f7043ddc06d184276230
DIST reflex-0.8.0.0.tar.gz 141007 BLAKE2B 6219f63abd6ba347c0583f0a9c448e13c998a8414666bd655ed090ea875637dcb100fe2ed65bb1eb94284a6554098fbc3912601312d33a06fa4baa94f87d5a45 SHA512 da7fbf77a7afc000ab5f54f6cb6f83b0aad3740ea4f75ba2469076d72a1c1f6d3eda05633d2c78b75aa4c0ea6dc31298ab2ba5be50e25436bb6eeb91d187c950
17 changes: 14 additions & 3 deletions dev-haskell/reflex/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -6,13 +6,24 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
<flag name="reflex-optimizer">Use the GHC plugin Reflex.Optimizer on some of the modules in the package. This is still experimental.</flag>
<flag name="template-haskell">Use template haskell to generate lenses</flag>
<flag name="debug-cycles">Enable debugging of event cycles</flag>
<flag name="debug-propagation">Enable debugging of spider internals</flag>
<flag name="debug-trace-events">Add instrumentation that outputs the stack trace of the definition of an event whenever it is subscribed to. Warning: It is very slow!</flag>
<flag name="fast-weak">Use the primitive implementation of FastWeak in GHCJS; note that this requires GHCJS to be built with FastWeak and FastWeakBag present in the RTS, which is not the default</flag>
<flag name="reflex-optimizer">Use the GHC plugin Reflex.Optimizer on some of the modules in the package. This is still experimental.</flag>
<flag name="split-these">Use split these/semialign packages</flag>
<flag name="template-haskell">Use template haskell to generate lenses</flag>
</use>
<longdescription>
Reflex is a high-performance, deterministic, higher-order Functional Reactive Programming system
Interactive programs without callbacks or side-effects.
Functional Reactive Programming (FRP) uses composable events and time-varying
values to describe interactive systems as pure functions.
Just like other pure functional code, functional reactive code is easier
to get right on the first try, maintain, and reuse.

Reflex is a fully-deterministic, higher-order Functional Reactive Programming
interface and an engine that efficiently implements that interface.

&lt;https://reflex-frp.org&gt;
</longdescription>
</pkgmetadata>
87 changes: 87 additions & 0 deletions dev-haskell/reflex/reflex-0.8.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

# ebuild generated by hackport 0.6.7.9999

CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal

DESCRIPTION="Higher-order Functional Reactive Programming"
HOMEPAGE="https://reflex-frp.org"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
# Removed the split-these flag since when it's not enabled, it requires an older
# version af these
IUSE="debug-cycles debug-propagation debug-trace-events fast-weak reflex-optimizer +template-haskell"

RDEPEND=">=dev-haskell/bifunctors-5.2:=[profile?] <dev-haskell/bifunctors-5.6:=[profile?]
>=dev-haskell/comonad-5.0.4:=[profile?] <dev-haskell/comonad-5.1:=[profile?]
>=dev-haskell/constraints-extras-0.3:=[profile?] <dev-haskell/constraints-extras-0.4:=[profile?]
>=dev-haskell/data-default-0.5:=[profile?] <dev-haskell/data-default-0.8:=[profile?]
>=dev-haskell/dependent-map-0.3:=[profile?] <dev-haskell/dependent-map-0.5:=[profile?]
>=dev-haskell/dependent-sum-0.6:=[profile?] <dev-haskell/dependent-sum-0.8:=[profile?]
>=dev-haskell/exception-transformers-0.4:=[profile?] <dev-haskell/exception-transformers-0.5:=[profile?]
>=dev-haskell/lens-4.7:=[profile?] <dev-haskell/lens-5:=[profile?]
>=dev-haskell/memotrie-0.6:=[profile?] <dev-haskell/memotrie-0.7:=[profile?]
>=dev-haskell/mmorph-1.0:=[profile?] <dev-haskell/mmorph-1.2:=[profile?]
>=dev-haskell/monad-control-1.0.1:=[profile?] <dev-haskell/monad-control-1.1:=[profile?]
>=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
>=dev-haskell/patch-0.0.1:=[profile?] <dev-haskell/patch-0.1:=[profile?]
>=dev-haskell/prim-uniq-0.1.0.1:=[profile?] <dev-haskell/prim-uniq-0.3:=[profile?]
>=dev-haskell/primitive-0.5:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
>=dev-haskell/profunctors-5.3:=[profile?]
>=dev-haskell/random-1.1:=[profile?] <dev-haskell/random-1.2:=[profile?]
>=dev-haskell/ref-tf-0.4:=[profile?] <dev-haskell/ref-tf-0.5:=[profile?]
>=dev-haskell/reflection-2.1:=[profile?] <dev-haskell/reflection-2.2:=[profile?]
>=dev-haskell/semigroupoids-4.0:=[profile?] <dev-haskell/semigroupoids-6:=[profile?]
>=dev-haskell/stm-2.4:=[profile?] <dev-haskell/stm-2.6:=[profile?]
>=dev-haskell/syb-0.5:=[profile?] <dev-haskell/syb-0.8:=[profile?]
>=dev-haskell/unbounded-delays-0.1.0.0:=[profile?] <dev-haskell/unbounded-delays-0.2:=[profile?]
>=dev-haskell/witherable-0.3:=[profile?] <dev-haskell/witherable-0.4:=[profile?]
>=dev-lang/ghc-8.6.5:=
reflex-optimizer? ( dev-lang/ghc:=[profile?] )
>=dev-haskell/monoidal-containers-0.6:=[profile?] <dev-haskell/monoidal-containers-0.7:=[profile?]
>=dev-haskell/semialign-1:=[profile?] <dev-haskell/semialign-1.2:=[profile?]
>=dev-haskell/these-1:=[profile?] <dev-haskell/these-1.2:=[profile?]
template-haskell? ( >=dev-haskell/haskell-src-exts-1.16:=[profile?] <dev-haskell/haskell-src-exts-1.24:=[profile?]
>=dev-haskell/haskell-src-meta-0.6:=[profile?] <dev-haskell/haskell-src-meta-0.9:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.4.0.1
test? ( dev-haskell/constraints
dev-haskell/filemanip
dev-haskell/hlint
dev-haskell/hspec
dev-haskell/proctest
dev-haskell/split
dev-haskell/text
dev-haskell/these-lens )
"

src_prepare() {
default

cabal_chdeps \
'base >= 4.9 && < 4.14' 'base >= 4.9' \
'template-haskell >= 2.9 && < 2.16' 'template-haskell >= 2.9' \
'profunctors >= 5.3 && < 5.6' 'profunctors >= 5.3' \
'hlint >= 3' 'hlint' \
'hlint (< 2.1 || >= 2.2.2) && < 3' 'hlint'

}

src_configure() {
haskell-cabal_src_configure \
--flag=split-these \
$(cabal_flag debug-cycles debug-cycles) \
$(cabal_flag debug-propagation debug-propagation) \
$(cabal_flag debug-trace-events debug-trace-events) \
$(cabal_flag fast-weak fast-weak) \
$(cabal_flag reflex-optimizer use-reflex-optimizer) \
$(cabal_flag template-haskell use-template-haskell)
}

0 comments on commit 6e3f138

Please sign in to comment.