Skip to content

Commit

Permalink
ramips: mt76x8: add support for Yuncore CPE200
Browse files Browse the repository at this point in the history
Yuncore CPE200 is an outdoor unit with IEEE 802.11ac radio.

Hardware:
 - SoC: MediaTek MT7628DAN (MIPS 580MHz)
 - Flash: 8 MiB Spansion S25FL064K
 - RAM: 64 MiB (built-into SoC)
 - WLAN: 5 GHz (MT7613AE)
 - Ethernet: 1x 10/100 Mbps WAN, 1x 10/100 LAN (MT7628)
 - Buttons: 1 Reset button, 2 buttons for display UI (unsupported)
 - LEDs: 4x Green (Power, LAN, WAN, WiFi)
 - Display: 4 digit 7-segment display driven by an additional
            microcontroller (unsupported)
 - Serial console: unpopulated header, 57600 8n1 (RX only)
 - Power: 12 VDC, 1 A

Installation:
The installation can be done via the recovery HTTP server which is built
into the bootloader. Hold down the reset button while connecting the
device to power and keep holding a bit more than 3 seconds. Connect to
http://192.168.0.100/ and upload sysupgrade.bin file.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  • Loading branch information
dangowrt committed Sep 2, 2024
1 parent 5fa86a4 commit a18464b
Show file tree
Hide file tree
Showing 4 changed files with 177 additions and 0 deletions.
164 changes: 164 additions & 0 deletions target/linux/ramips/dts/mt7628an_yuncore_cpe200.dts
Original file line number Diff line number Diff line change
@@ -0,0 +1,164 @@
#include "mt7628an.dtsi"

#include <dt-bindings/gpio/gpio.h>
#include <dt-bindings/input/input.h>
#include <dt-bindings/leds/common.h>

/ {
compatible = "yuncore,cpe200", "mediatek,mt7628an-soc";

chosen {
bootargs = "console=ttyS0,57600";
};

aliases {
label-mac = &ethernet;
led-boot = &led_power;
led-failsafe = &led_power;
led-running = &led_power;
led-upgrade = &led_power;
};

keys {
compatible = "gpio-keys";

reset {
label = "reset";
gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
linux,code = <KEY_RESTART>;
};

mode {
label = "mode";
linux,input-type = <EV_SW>;
linux,code = <BTN_0>;
gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
debounce-interval = <60>;
};
};

leds {
compatible = "gpio-leds";

led_power: power {
function = LED_FUNCTION_POWER;
color = <LED_COLOR_ID_GREEN>;
gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
};

lan {
function = LED_FUNCTION_LAN;
color = <LED_COLOR_ID_GREEN>;
gpios = <&gpio 43 GPIO_ACTIVE_LOW>;
};

wan {
function = LED_FUNCTION_WAN;
color = <LED_COLOR_ID_GREEN>;
gpios = <&gpio 39 GPIO_ACTIVE_LOW>;
};
};

watchdog {
compatible = "linux,wdt-gpio";
gpios = <&gpio 37 GPIO_ACTIVE_HIGH>;
hw_algo = "toggle";
hw_margin_ms = <20000>;
always-running;
};
};

&spi0 {
status = "okay";

flash@0 {
compatible = "jedec,spi-nor";
reg = <0>;
spi-max-frequency = <10000000>;

partitions {
compatible = "fixed-partitions";
#address-cells = <1>;
#size-cells = <1>;

partition@0 {
label = "u-boot";
reg = <0x0 0x30000>;
read-only;
};

partition@30000 {
label = "u-boot-env";
reg = <0x30000 0x10000>;
read-only;
};

partition@40000 {
label = "factory";
reg = <0x40000 0x10000>;
read-only;

nvmem-layout {
compatible = "fixed-layout";
#address-cells = <1>;
#size-cells = <1>;

macaddr_factory_4: macaddr@4 {
reg = <0x4 0x6>;
};

eeprom_factory_8000: eeprom@8000 {
reg = <0x8000 0x600>;
};

macaddr_factory_8004: macaddr@8004 {
reg = <0x8004 0x6>;
};
};
};

partition@50000 {
compatible = "denx,uimage";
label = "firmware";
reg = <0x50000 0x7b0000>;
};
};
};
};

&ethernet {
nvmem-cells = <&macaddr_factory_4>;
nvmem-cell-names = "mac-address";
};

&esw {
mediatek,portmap = <0x2f>;
};

&pcie {
status = "okay";
};

&pcie0 {
mt76@0,0 {
reg = <0x0000 0 0 0 0>;
ieee80211-freq-limit = <5000000 6000000>;
nvmem-cells = <&eeprom_factory_8000>, <&macaddr_factory_8004>;
nvmem-cell-names = "eeprom", "mac-address";

led {
led-sources = <0>;
led-active-low;
};
};
};

&state_default {
gpio {
groups = "pwm0", "i2c", "refclk", "wdt", "i2s", "spi cs1",
"spis", "gpio", "p0led_an", "p1led_an", "p2led_an",
"p3led_an", "p4led_an", "wled_kn", "p0led_kn",
"p1led_kn", "p2led_kn", "p3led_kn", "p4led_kn", "wled_an";
function = "gpio";
};
};
8 changes: 8 additions & 0 deletions target/linux/ramips/image/mt76x8.mk
Original file line number Diff line number Diff line change
Expand Up @@ -1136,6 +1136,14 @@ define Device/xiaomi_mi-ra75
endef
TARGET_DEVICES += xiaomi_mi-ra75

define Device/yuncore_cpe200
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Yuncore
DEVICE_MODEL := CPE200
DEVICE_PACKAGES := -kmod-mt7603 kmod-mt7615e kmod-mt7663-firmware-ap kmod-mt7663-firmware-sta
endef
TARGET_DEVICES += yuncore_cpe200

define Device/yuncore_m300
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Yuncore
Expand Down
1 change: 1 addition & 0 deletions target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
Original file line number Diff line number Diff line change
Expand Up @@ -19,6 +19,7 @@ asus,rt-n12-vp-b1|\
netgear,r6020|\
netgear,r6080|\
netgear,r6120|\
yuncore,cpe200|\
yuncore,m300)
ucidef_set_led_switch "lan" "lan" "green:lan" "switch0" "0xf"
ucidef_set_led_switch "wan" "wan" "green:wan" "switch0" "0x10"
Expand Down
4 changes: 4 additions & 0 deletions target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
Original file line number Diff line number Diff line change
Expand Up @@ -204,6 +204,10 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"0:lan:2" "2:lan:1" "4:wan" "6@eth0"
;;
yuncore,cpe200)
ucidef_add_switch "switch0" \
"0:lan" "4:wan" "6@eth0"
;;
zbtlink,zbt-we1226)
ucidef_add_switch "switch0" \
"0:lan:2" "1:lan:1" "4:wan" "6@eth0"
Expand Down

0 comments on commit a18464b

Please sign in to comment.