Skip to content

Commit

Permalink
kernel: add driver for Airoha EN8811H PHY as module
Browse files Browse the repository at this point in the history
Add PHY driver for Airoha EN8811H PHY and package it as kernel module.
The PHY needs to load firmware from rootfs, so there is no point in
having the driver built-into the kernel.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  • Loading branch information
dangowrt committed Feb 1, 2024
1 parent 0aecc8a commit bb3701b
Show file tree
Hide file tree
Showing 6 changed files with 1,048 additions and 7 deletions.
17 changes: 17 additions & 0 deletions package/kernel/linux/modules/netdevices.mk
Original file line number Diff line number Diff line change
Expand Up @@ -375,6 +375,23 @@ endef
$(eval $(call KernelPackage,phy-smsc))


define KernelPackage/phy-airoha-en8811h
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Airoha EN8811H 2.5G Ethernet PHY
DEPENDS:=+airoha-en8811h-firmware +kmod-libphy @LINUX_6_1
KCONFIG:=CONFIG_AIR_EN8811H_PHY
FILES:= \
$(LINUX_DIR)/drivers/net/phy/air_en8811h.ko
AUTOLOAD:=$(call AutoLoad,18,air_en8811h,1)
endef

define KernelPackage/phy-airoha-en8811h/description
Kernel modules for Airoha EN8811H 2.5G Ethernet PHY
endef

$(eval $(call KernelPackage,phy-airoha-en8811h))


define KernelPackage/phy-aquantia
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Aquantia Ethernet PHYs
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -92,7 +92,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
+
comment "MII PHY device drivers"

config AMD_PHY
config AIR_EN8811H_PHY
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -24,6 +24,21 @@ libphy-$(CONFIG_LED_TRIGGER_PHY) += phy_
Expand Down
Loading

0 comments on commit bb3701b

Please sign in to comment.