Skip to content

Commit

Permalink
Merge pull request #6445 from Ayushmanwebdeveloper/luci-app-olsr-js-mig
Browse files Browse the repository at this point in the history
luci-app-olsr: migrate to JavaScript-based implementation
  • Loading branch information
jow- authored Jul 25, 2023
2 parents 075b86c + ebd0933 commit 5d5cf55
Show file tree
Hide file tree
Showing 48 changed files with 4,619 additions and 3,344 deletions.
2 changes: 1 addition & 1 deletion applications/luci-app-olsr/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk

LUCI_TITLE:=OLSR configuration and status module
LUCI_DEPENDS:=+luci-compat +olsrd +olsrd-mod-jsoninfo +luci-lib-json
LUCI_DEPENDS:=+olsrd

include ../../luci.mk

Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
function css(selector, property, value) {
for (var i = 0; i < document.styleSheets.length; i++) {
try {
document.styleSheets[i].insertRule(selector + ' {' + property + ':' + value + '}', document.styleSheets[i].cssRules.length);
} catch (err) {
try {
document.styleSheets[i].addRule(selector, property + ':' + value);
} catch (err) {}
} //IE
}
}

window.onload = function () {
var buttons = '<input type="button" name="show-proto-4" id="show-proto-4" class="cbi-button cbi-button-apply" style="margin-right: 5px" value="<%:Hide IPv4%>">';
buttons += '<input type="button" name="show-proto-6" id="show-proto-6" class="cbi-button cbi-button-apply" value="<%:Hide IPv6%>">';

document.getElementById('togglebuttons').innerHTML = buttons;

var visible = true;
document.getElementById('show-proto-4').onclick = function () {
visible = !visible;
document.getElementById('show-proto-4').value = visible ? '<%:Hide IPv4%>' : '<%:Show IPv4%>';
document.getElementById('show-proto-4').className = visible ? 'cbi-button cbi-button-apply' : 'cbi-button cbi-button-reset';
css('.proto-4', 'display', visible ? 'table-row' : 'none');
};

var visible6 = true;
document.getElementById('show-proto-6').onclick = function () {
visible6 = !visible6;
document.getElementById('show-proto-6').value = visible6 ? '<%:Hide IPv6%>' : '<%:Show IPv6%>';
document.getElementById('show-proto-6').className = visible6 ? 'cbi-button cbi-button-apply' : 'cbi-button cbi-button-reset';
css('.proto-6', 'display', visible6 ? 'table-row' : 'none');
};
};
Loading

0 comments on commit 5d5cf55

Please sign in to comment.