-
Notifications
You must be signed in to change notification settings - Fork 2.5k
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Add a File Browser based on the FileUpload CBI element. It allows browsing files and directories on a router, delete and upload. This covers only basic needs. Signed-off-by: Sergey Ponomarev <stokito@gmail.com>
- Loading branch information
Showing
5 changed files
with
87 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
# This is free software, licensed under the Apache License, Version 2.0 . | ||
|
||
include $(TOPDIR)/rules.mk | ||
|
||
LUCI_TITLE:=LuCI File Browser module | ||
LUCI_DEPENDS:=+luci-base | ||
|
||
PKG_LICENSE:=Apache-2.0 | ||
PKG_VERSION:=1.1.0 | ||
PKG_RELEASE:=1 | ||
PKG_MAINTAINER:=Sergey Ponomarev <stokito@gmail.com> | ||
|
||
include ../../luci.mk | ||
|
||
# call BuildPackage - OpenWrt buildroot signature |
34 changes: 34 additions & 0 deletions
34
applications/luci-app-filebrowser/htdocs/luci-static/resources/view/system/filebrowser.js
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
'use strict'; | ||
'require view'; | ||
'require ui'; | ||
'require form'; | ||
|
||
var formData = { | ||
files: { | ||
root: null, | ||
} | ||
}; | ||
|
||
return view.extend({ | ||
render: function() { | ||
var m, s, o; | ||
|
||
m = new form.JSONMap(formData, _('File Browser'), ''); | ||
|
||
s = m.section(form.NamedSection, 'files', 'files'); | ||
|
||
o = s.option(form.FileUpload, 'root', ''); | ||
o.root_directory = '/'; | ||
o.browser = true; | ||
o.show_hidden = true; | ||
o.enable_upload = true; | ||
o.enable_remove = true; | ||
o.enable_download = true; | ||
|
||
return m.render(); | ||
}, | ||
|
||
handleSave: null, | ||
handleSaveApply: null, | ||
handleReset: null | ||
}) |
11 changes: 11 additions & 0 deletions
11
applications/luci-app-filebrowser/po/templates/filebrowser.pot
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
msgid "" | ||
msgstr "Content-Type: text/plain; charset=UTF-8" | ||
|
||
#: applications/luci-app-filebrowser/htdocs/luci-static/resources/view/system/filebrowser.js:16 | ||
#: applications/luci-app-filebrowser/root/usr/share/luci/menu.d/luci-app-filebrowser.json:3 | ||
msgid "File Browser" | ||
msgstr "" | ||
|
||
#: applications/luci-app-filebrowser/root/usr/share/rpcd/acl.d/luci-app-filebrowser.json:3 | ||
msgid "Grant access to File Browser" | ||
msgstr "" |
13 changes: 13 additions & 0 deletions
13
applications/luci-app-filebrowser/root/usr/share/luci/menu.d/luci-app-filebrowser.json
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
{ | ||
"admin/system/filebrowser": { | ||
"title": "File Browser", | ||
"order": 80, | ||
"action": { | ||
"type": "view", | ||
"path": "system/filebrowser" | ||
}, | ||
"depends": { | ||
"acl": [ "luci-app-filebrowser" ] | ||
} | ||
} | ||
} |
14 changes: 14 additions & 0 deletions
14
applications/luci-app-filebrowser/root/usr/share/rpcd/acl.d/luci-app-filebrowser.json
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
{ | ||
"luci-app-filebrowser": { | ||
"description": "Grant access to File Browser", | ||
"write": { | ||
"cgi-io": [ "upload", "download" ], | ||
"ubus": { | ||
"file": [ "*" ] | ||
}, | ||
"file": { | ||
"/*": [ "list", "read", "write" ] | ||
} | ||
} | ||
} | ||
} |