Skip to content

Commit

Permalink
luci-app-olsr: migrate to js
Browse files Browse the repository at this point in the history
Signed-off-by: Ayushman Tripathi <ayushmantripathi7724@gmail.com>

luci-app-olsr: migrate to js fix XSS vulnerability

Signed-off-by: Ayushman Tripathi <ayushmantripathi7724@gmail.com>

luci-app-olsr: migrate to js

luci-app-olsr: migrate to js fix minor bugs

Signed-off-by: Ayushman Tripathi <ayushmantripathi7724@gmail.com>

luci-app-olsr: migrate to js

luci-app-olsr: migrate to js fix plugins bugs

Signed-off-by: Ayushman Tripathi <ayushmantripathi7724@gmail.com>

luci-app-olsr: migrate to js

luci-app-olsr: migrate to js fix interfaces bugs

Signed-off-by: Ayushman Tripathi <ayushmantripathi7724@gmail.com>

luci-app-olsr: migrate to js

luci-app-olsr: migrate to js fix interface & snr bugs

Signed-off-by: Ayushman Tripathi <ayushmantripathi7724@gmail.com>

luci-app-olsr: migrate to js
  • Loading branch information
Ayushmanwebdeveloper committed Jul 5, 2023
1 parent fd5440a commit 6d65aee
Show file tree
Hide file tree
Showing 50 changed files with 4,521 additions and 3,355 deletions.
2 changes: 1 addition & 1 deletion applications/luci-app-olsr/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk

LUCI_TITLE:=OLSR configuration and status module
LUCI_DEPENDS:=+luci-compat +olsrd +olsrd-mod-jsoninfo +luci-lib-json
LUCI_DEPENDS:=+luci-compat +olsrd

include ../../luci.mk

Expand Down
1 change: 0 additions & 1 deletion applications/luci-app-olsr/htdocs/cgi-bin-nodes.html

This file was deleted.

10 changes: 0 additions & 10 deletions applications/luci-app-olsr/htdocs/cgi-bin-status.html

This file was deleted.

Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
function css(selector, property, value) {
for (var i = 0; i < document.styleSheets.length; i++) {
try {
document.styleSheets[i].insertRule(selector + ' {' + property + ':' + value + '}', document.styleSheets[i].cssRules.length);
} catch (err) {
try {
document.styleSheets[i].addRule(selector, property + ':' + value);
} catch (err) {}
} //IE
}
}

window.onload = function () {
var buttons = '<input type="button" name="show-proto-4" id="show-proto-4" class="cbi-button cbi-button-apply" style="margin-right: 5px" value="<%:Hide IPv4%>">';
buttons += '<input type="button" name="show-proto-6" id="show-proto-6" class="cbi-button cbi-button-apply" value="<%:Hide IPv6%>">';

document.getElementById('togglebuttons').innerHTML = buttons;

var visible = true;
document.getElementById('show-proto-4').onclick = function () {
visible = !visible;
document.getElementById('show-proto-4').value = visible ? '<%:Hide IPv4%>' : '<%:Show IPv4%>';
document.getElementById('show-proto-4').className = visible ? 'cbi-button cbi-button-apply' : 'cbi-button cbi-button-reset';
css('.proto-4', 'display', visible ? 'table-row' : 'none');
};

var visible6 = true;
document.getElementById('show-proto-6').onclick = function () {
visible6 = !visible6;
document.getElementById('show-proto-6').value = visible6 ? '<%:Hide IPv6%>' : '<%:Show IPv6%>';
document.getElementById('show-proto-6').className = visible6 ? 'cbi-button cbi-button-apply' : 'cbi-button cbi-button-reset';
css('.proto-6', 'display', visible6 ? 'table-row' : 'none');
};
};
Loading

0 comments on commit 6d65aee

Please sign in to comment.