Skip to content

Commit

Permalink
tools: refresh all patches
Browse files Browse the repository at this point in the history
Refresh all tools patches now that tools/refresh correctly works.

CI now checks for them and actively complain if tools have unrefreshed
patches.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
  • Loading branch information
Ansuel committed May 22, 2024
1 parent 349c3c1 commit 28bf013
Show file tree
Hide file tree
Showing 13 changed files with 67 additions and 97 deletions.
10 changes: 5 additions & 5 deletions tools/bzip2/patches/021-merge-and-improve-makefiles.patch
Original file line number Diff line number Diff line change
Expand Up @@ -22,7 +22,7 @@

--- a/Makefile
+++ b/Makefile
@@ -21,11 +21,38 @@
@@ -21,11 +21,38 @@ RANLIB=ranlib
LDFLAGS=

BIGFILES=-D_FILE_OFFSET_BITS=64
Expand Down Expand Up @@ -64,7 +64,7 @@

OBJS= blocksort.o \
huffman.o \
@@ -35,15 +62,38 @@
@@ -35,15 +62,38 @@ OBJS= blocksort.o \
decompress.o \
bzlib.o

Expand Down Expand Up @@ -109,7 +109,7 @@
rm -f libbz2.a
$(AR) cq libbz2.a $(OBJS)
@if ( test -f $(RANLIB) -o -f /usr/bin/ranlib -o \
@@ -51,8 +101,18 @@
@@ -51,8 +101,18 @@ libbz2.a: $(OBJS)
echo $(RANLIB) libbz2.a ; \
$(RANLIB) libbz2.a ; \
fi
Expand All @@ -129,7 +129,7 @@
test: bzip2
@cat words1
./bzip2 -1 < sample1.ref > sample1.rb2
@@ -69,69 +129,153 @@
@@ -69,69 +129,153 @@ test: bzip2
cmp sample3.tst sample3.ref
@cat words3

Expand Down Expand Up @@ -318,7 +318,7 @@


distclean: clean
@@ -189,7 +333,6 @@
@@ -189,7 +333,6 @@ dist: check manual
$(DISTNAME)/bzmore.1 \
$(DISTNAME)/bzgrep \
$(DISTNAME)/bzgrep.1 \
Expand Down
2 changes: 1 addition & 1 deletion tools/ccache/patches/100-honour-copts.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/src/ccache.cpp
+++ b/src/ccache.cpp
@@ -1813,6 +1813,7 @@ get_manifest_key(Context& ctx, Hash& has
@@ -1815,6 +1815,7 @@ get_manifest_key(Context& ctx, Hash& has
"CPLUS_INCLUDE_PATH",
"OBJC_INCLUDE_PATH",
"OBJCPLUS_INCLUDE_PATH", // clang
Expand Down
6 changes: 3 additions & 3 deletions tools/elftosb/patches/001-libm.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- elftosb-10.12.01/makefile.rules 2012-03-15 11:01:44.979020178 -0400
+++ elftosb-10.12.01/makefile.rules 2012-03-15 11:01:16.332761989 -0400
@@ -101,7 +101,7 @@
--- a/makefile.rules
+++ b/makefile.rules
@@ -101,7 +101,7 @@ OBJ_FILES_KEYGEN = \
keygen.o


Expand Down
5 changes: 2 additions & 3 deletions tools/elftosb/patches/002-fix-header-path.patch
Original file line number Diff line number Diff line change
Expand Up @@ -5,9 +5,8 @@ others once multiarch becomes more common.
This patch makes the types a relative path, and allows the system
to use whatever include paths it feels are correct.

diff -Naurp elftosb-10.12.01-orig/common/stdafx.h elftosb-10.12.01/common/stdafx.h
--- elftosb-10.12.01-orig/common/stdafx.h 2012-07-12 13:30:10.990249396 -0400
+++ elftosb-10.12.01/common/stdafx.h 2012-07-12 13:30:06.858249391 -0400
--- a/common/stdafx.h
+++ b/common/stdafx.h
@@ -27,7 +27,7 @@
// For Linux systems only, types.h only defines the signed
// integer types. This is not professional code.
Expand Down
14 changes: 7 additions & 7 deletions tools/liblzo/patches/001-add-cmake-ENABLE-configurables.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/CMakeLists.txt 2022-11-28 06:34:39.171209779 -0800
+++ b/CMakeLists.txt 2022-11-28 06:33:13.368239757 -0800
@@ -51,8 +51,11 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,8 +51,11 @@ endif()
project(lzo VERSION 2.10 LANGUAGES C)

# configuration options
Expand All @@ -14,7 +14,7 @@
if(NOT ENABLE_STATIC AND NOT ENABLE_SHARED)
set(ENABLE_STATIC ON)
endif()
@@ -127,14 +130,20 @@
@@ -127,14 +130,20 @@ macro(lzo_add_executable t)
endif()
endmacro()
# main test driver
Expand All @@ -35,7 +35,7 @@
# some boring internal test programs
if(0)
lzo_add_executable(align tests/align.c)
@@ -144,7 +153,7 @@
@@ -144,7 +153,7 @@ if(0)
endif()

# miniLZO
Expand All @@ -44,7 +44,7 @@
add_executable(testmini minilzo/testmini.c minilzo/minilzo.c)
target_include_directories(testmini PRIVATE "${CMAKE_CURRENT_SOURCE_DIR}/include/lzo") # needed for "lzoconf.h"
endif()
@@ -263,8 +272,10 @@
@@ -263,8 +272,10 @@ add_test(NAME lzotest-03 COMMAND lzotest

if(DEFINED CMAKE_INSTALL_FULL_LIBDIR)

Expand All @@ -57,7 +57,7 @@

set(f include/lzo/lzo1.h include/lzo/lzo1a.h include/lzo/lzo1b.h
include/lzo/lzo1c.h include/lzo/lzo1f.h include/lzo/lzo1x.h
@@ -285,7 +296,7 @@
@@ -285,7 +296,7 @@ if(ENABLE_SHARED)
)
endif()

Expand Down
14 changes: 7 additions & 7 deletions tools/lz4/patches/001-add-make-ENABLE_DOCS-configurable.patch
Original file line number Diff line number Diff line change
@@ -1,30 +1,30 @@
+++ a/programs/Makefile 2022-08-15 15:45:31.000000000 -0700
--- b/programs/Makefile 2022-11-28 16:34:21.315593784 -0800
@@ -66,6 +66,7 @@
--- a/programs/Makefile
+++ b/programs/Makefile
@@ -66,6 +66,7 @@ LZ4_VERSION=$(LIBVER)
MD2ROFF = ronn
MD2ROFF_FLAGS = --roff --warnings --manual="User Commands" --organization="lz4 $(LZ4_VERSION)"

+ENABLE_DOCS ?= 1

default: lz4-release

@@ -120,6 +121,7 @@
@@ -120,6 +121,7 @@ lz4c32: CFLAGS += -m32
lz4c32 : $(SRCFILES)
$(CC) $(FLAGS) $^ -o $@$(EXT)

+ifeq ($(ENABLE_DOCS),1)
lz4.1: lz4.1.md $(LIBVER_SRC)
cat $< | $(MD2ROFF) $(MD2ROFF_FLAGS) | $(SED) -n '/^\.\\\".*/!p' > $@

@@ -130,6 +132,7 @@
@@ -130,6 +132,7 @@ clean-man:

preview-man: clean-man man
man ./lz4.1
+endif

clean:
ifeq ($(WINBASED),yes)
@@ -172,16 +175,19 @@
@@ -172,16 +175,19 @@ man1dir ?= $(MAN1DIR)

install: lz4
@echo Installing binaries in $(DESTDIR)$(bindir)
Expand All @@ -45,7 +45,7 @@
@echo lz4 installation completed

uninstall:
@@ -189,10 +195,12 @@
@@ -189,10 +195,12 @@ uninstall:
$(RM) $(DESTDIR)$(bindir)/unlz4$(EXT)
$(RM) $(DESTDIR)$(bindir)/lz4$(EXT)
$(RM) $(DESTDIR)$(bindir)/lz4c$(EXT)
Expand Down
23 changes: 10 additions & 13 deletions tools/lz4/patches/002-makefile-install-links-from-same-dir.patch
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
diff -ur a/lib/Makefile b/lib/Makefile
--- a/lib/Makefile 2022-12-04 23:49:06.336839263 -0800
+++ b/lib/Makefile 2022-12-05 00:00:59.172307488 -0800
@@ -195,8 +195,8 @@
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -195,8 +195,8 @@ install: lib liblz4.pc
$(INSTALL_PROGRAM) dll/$(LIBLZ4_EXP) $(DESTDIR)$(libdir)
else
$(INSTALL_PROGRAM) liblz4.$(SHARED_EXT_VER) $(DESTDIR)$(libdir)
Expand All @@ -12,10 +11,9 @@ diff -ur a/lib/Makefile b/lib/Makefile
endif
endif
@echo Installing headers in $(DESTDIR)$(includedir)
diff -ur a/Makefile b/Makefile
--- a/Makefile 2022-12-04 23:49:06.336839263 -0800
+++ b/Makefile 2022-12-04 23:42:09.693836654 -0800
@@ -77,12 +77,12 @@
--- a/Makefile
+++ b/Makefile
@@ -77,12 +77,12 @@ build_tests:

.PHONY: clean
clean:
Expand All @@ -34,10 +32,9 @@ diff -ur a/Makefile b/Makefile
$(RM) lz4$(EXT)
$(RM) -r $(CMAKE_BUILD_DIR)
@echo Cleaning completed
diff -ur a/programs/Makefile b/programs/Makefile
--- a/programs/Makefile 2022-12-04 23:49:06.336839263 -0800
+++ b/programs/Makefile 2022-12-04 23:42:30.849582910 -0800
@@ -138,7 +138,7 @@
--- a/programs/Makefile
+++ b/programs/Makefile
@@ -138,7 +138,7 @@ clean:
ifeq ($(WINBASED),yes)
$(RM) *.rc
endif
Expand All @@ -46,7 +43,7 @@ diff -ur a/programs/Makefile b/programs/Makefile
$(RM) core *.o *.test tmp* \
lz4$(EXT) lz4c$(EXT) lz4c32$(EXT) lz4-wlib$(EXT) \
unlz4$(EXT) lz4cat$(EXT)
@@ -177,16 +177,16 @@
@@ -177,16 +177,16 @@ install: lz4
@echo Installing binaries in $(DESTDIR)$(bindir)
$(INSTALL_DIR) $(DESTDIR)$(bindir)/
$(INSTALL_PROGRAM) lz4$(EXT) $(DESTDIR)$(bindir)/lz4$(EXT)
Expand Down
8 changes: 3 additions & 5 deletions tools/lzma/patches/001-large_files.patch
Original file line number Diff line number Diff line change
@@ -1,8 +1,6 @@
Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
===================================================================
--- lzma-4.65.orig/CPP/7zip/Compress/LZMA_Alone/makefile.gcc 2009-05-15 23:33:51.000000000 +0200
+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc 2009-06-01 22:00:54.000000000 +0200
@@ -3,7 +3,7 @@
--- a/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
+++ b/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
@@ -3,7 +3,7 @@ CXX = g++ -O2 -Wall
CXX_C = gcc -O2 -Wall
LIB = -lm
RM = rm -f
Expand Down
36 changes: 13 additions & 23 deletions tools/lzma/patches/002-lzmp.patch
Original file line number Diff line number Diff line change
@@ -1,7 +1,5 @@
Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzmp.cpp
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzmp.cpp 2009-06-01 22:01:10.000000000 +0200
--- /dev/null
+++ b/CPP/7zip/Compress/LZMA_Alone/lzmp.cpp
@@ -0,0 +1,895 @@
+/*
+ * LZMA command line tool similar to gzip to encode and decode LZMA files.
Expand Down Expand Up @@ -898,10 +896,8 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzmp.cpp
+ return STATUS_OK;
+}
+
Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/Exception.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/Exception.h 2009-06-01 22:01:10.000000000 +0200
--- /dev/null
+++ b/CPP/7zip/Compress/LZMA_Alone/Exception.h
@@ -0,0 +1,45 @@
+/* A couple of exceptions for lzmp.
+ *
Expand Down Expand Up @@ -948,10 +944,8 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/Exception.h
+
+#endif
+
Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
===================================================================
--- lzma-4.65.orig/CPP/7zip/Compress/LZMA_Alone/makefile.gcc 2009-06-01 22:00:54.000000000 +0200
+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc 2009-06-01 22:06:13.000000000 +0200
--- a/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
+++ b/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
@@ -1,9 +1,10 @@
-PROG = lzma
+PROG = lzma_alone
Expand All @@ -965,7 +959,7 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc

ifdef SystemDrive
IS_MINGW = 1
@@ -45,12 +46,35 @@
@@ -45,12 +46,35 @@ OBJS = \
Lzma86Dec.o \
Lzma86Enc.o \

Expand Down Expand Up @@ -1002,17 +996,15 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/makefile.gcc
LzmaAlone.o: LzmaAlone.cpp
$(CXX) $(CFLAGS) LzmaAlone.cpp

@@ -131,5 +153,5 @@
@@ -131,5 +155,5 @@ Lzma86Enc.o: ../../../../C/LzmaUtil/Lzma
$(CXX_C) $(CFLAGS) ../../../../C/LzmaUtil/Lzma86Enc.c

clean:
- -$(RM) $(PROG) $(OBJS)
+ -$(RM) $(PROG) $(PROG2) $(OBJS)

Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzma_version.h
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzma_version.h 2009-06-01 22:01:10.000000000 +0200
--- /dev/null
+++ b/CPP/7zip/Compress/LZMA_Alone/lzma_version.h
@@ -0,0 +1,31 @@
+#ifndef LZMA_VERSION_H
+#define LZMA_VERSION_H
Expand Down Expand Up @@ -1045,11 +1037,9 @@ Index: lzma-4.65/CPP/7zip/Compress/LZMA_Alone/lzma_version.h
+ "named COPYING.\n";
+
+#endif /* ifndef LZMA_VERSION_H */
Index: lzma-4.65/CPP/Common/C_FileIO.h
===================================================================
--- lzma-4.65.orig/CPP/Common/C_FileIO.h 2009-05-15 23:33:51.000000000 +0200
+++ lzma-4.65/CPP/Common/C_FileIO.h 2009-06-01 22:06:56.000000000 +0200
@@ -24,6 +24,7 @@
--- a/CPP/Common/C_FileIO.h
+++ b/CPP/Common/C_FileIO.h
@@ -24,6 +24,7 @@ public:
bool Close();
bool GetLength(UInt64 &length) const;
off_t Seek(off_t distanceToMove, int moveMethod) const;
Expand Down
14 changes: 6 additions & 8 deletions tools/lzma/patches/003-compile_fixes.patch
Original file line number Diff line number Diff line change
@@ -1,18 +1,16 @@
diff -urN lzma-4.65/CPP/7zip/Common/FileStreams.h lzma-4.65.new/CPP/7zip/Common/FileStreams.h
--- lzma-4.65/CPP/7zip/Common/FileStreams.h 2009-05-15 23:33:51.000000000 +0200
+++ lzma-4.65.new/CPP/7zip/Common/FileStreams.h 2009-06-01 22:30:01.000000000 +0200
@@ -72,6 +72,7 @@
--- a/CPP/7zip/Common/FileStreams.h
+++ b/CPP/7zip/Common/FileStreams.h
@@ -72,6 +72,7 @@ class COutFileStream:
public IOutStream,
public CMyUnknownImp
{
+public:
#ifdef USE_WIN_FILE
NWindows::NFile::NIO::COutFile File;
#else
diff -urN lzma-4.65/CPP/Common/MyWindows.h lzma-4.65.new/CPP/Common/MyWindows.h
--- lzma-4.65/CPP/Common/MyWindows.h 2009-05-15 23:33:51.000000000 +0200
+++ lzma-4.65.new/CPP/Common/MyWindows.h 2009-06-01 22:29:26.000000000 +0200
@@ -101,8 +101,11 @@
--- a/CPP/Common/MyWindows.h
+++ b/CPP/Common/MyWindows.h
@@ -101,8 +101,11 @@ typedef LONG SCODE;

#ifdef __cplusplus

Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/CMakeLists.txt 2017-08-10 04:19:45.000000000 -0700
+++ b/CMakeLists.txt 2022-11-28 17:21:03.453548350 -0800
@@ -50,6 +50,9 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,9 @@ endif()

project(lzop VERSION 1.04 LANGUAGES C)

Expand All @@ -10,7 +10,7 @@
# install directories
if(NOT CMAKE_INSTALL_PREFIX)
message(FATAL_ERROR "ERROR: CMAKE_INSTALL_PREFIX is not defined.")
@@ -186,9 +189,11 @@
@@ -186,9 +189,11 @@ if(DEFINED CMAKE_INSTALL_FULL_LIBDIR)

install(TARGETS lzop DESTINATION "${CMAKE_INSTALL_FULL_BINDIR}")

Expand Down
Loading

0 comments on commit 28bf013

Please sign in to comment.