Skip to content

Commit

Permalink
Merge pull request #66 from openwrtdiy/openwrt-23.05
Browse files Browse the repository at this point in the history
Openwrt 23.05
  • Loading branch information
openwrtdiy authored Sep 24, 2023
2 parents 02298f9 + 9349302 commit 838f25c
Show file tree
Hide file tree
Showing 16 changed files with 302 additions and 37 deletions.
2 changes: 2 additions & 0 deletions package/firmware/ipq-wifi/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -41,6 +41,7 @@ ALLWIFIBOARDS:= \
xiaomi_ax3600 \
xiaomi_ax9000 \
zte_mf289f \
zte_mf287 \
zte_mf287plus \
zyxel_nbg7815

Expand Down Expand Up @@ -129,6 +130,7 @@ $(eval $(call generate-ipq-wifi-package,wallys_dr40x9,Wallys DR40X9))
$(eval $(call generate-ipq-wifi-package,xiaomi_ax3600,Xiaomi AX3600))
$(eval $(call generate-ipq-wifi-package,xiaomi_ax9000,Xiaomi AX9000))
$(eval $(call generate-ipq-wifi-package,zte_mf289f,ZTE MF289F))
$(eval $(call generate-ipq-wifi-package,zte_mf287,ZTE MF287))
$(eval $(call generate-ipq-wifi-package,zte_mf287plus,ZTE MF287Plus))
$(eval $(call generate-ipq-wifi-package,zyxel_nbg7815,Zyxel NBG7815))

Expand Down
4 changes: 2 additions & 2 deletions package/firmware/wireless-regdb/Makefile
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=wireless-regdb
PKG_VERSION:=2023.05.03
PKG_VERSION:=2023.09.01
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/network/wireless-regdb/
PKG_HASH:=f254d08ab3765aeae2b856222e11a95d44aef519a6663877c71ef68fae4c8c12
PKG_HASH:=26d4c2a727cc59239b84735aad856b7c7d0b04e30aa5c235c4f7f47f5f053491

PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>

Expand Down
4 changes: 2 additions & 2 deletions package/libs/openssl/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=openssl
PKG_VERSION:=3.0.10
PKG_VERSION:=3.0.11
PKG_RELEASE:=1
PKG_BUILD_FLAGS:=no-mips16 gc-sections no-lto

Expand All @@ -24,7 +24,7 @@ PKG_SOURCE_URL:= \
ftp://ftp.pca.dfn.de/pub/tools/net/openssl/source/ \
ftp://ftp.pca.dfn.de/pub/tools/net/openssl/source/old/$(PKG_BASE)/

PKG_HASH:=1761d4f5b13a1028b9b6f3d4b8e17feb0cedc9370f6afe61d7193d2cdce83323
PKG_HASH:=b3425d3bb4a2218d0697eb41f7fc0cdede016ed19ca49d168b78e8d947887f55

PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE
Expand Down
10 changes: 5 additions & 5 deletions package/network/services/hostapd/patches/601-ucode_support.patch
Original file line number Diff line number Diff line change
Expand Up @@ -107,14 +107,14 @@
hostapd_ubus_free_bss(hapd);
accounting_deinit(hapd);
hostapd_deinit_wpa(hapd);
@@ -570,6 +573,7 @@ static void sta_track_deinit(struct host
void hostapd_cleanup_iface_partial(struct hostapd_iface *iface)
@@ -600,6 +603,7 @@ void hostapd_cleanup_iface_partial(struc
static void hostapd_cleanup_iface(struct hostapd_iface *iface)
{
wpa_printf(MSG_DEBUG, "%s(%p)", __func__, iface);
+ hostapd_ucode_free_iface(iface);
eloop_cancel_timeout(channel_list_update_timeout, iface, NULL);
#ifdef NEED_AP_MLME
hostapd_stop_setup_timers(iface);
eloop_cancel_timeout(hostapd_interface_setup_failure_handler, iface,
NULL);

@@ -1189,6 +1193,7 @@ static int hostapd_start_beacon(struct h
hapd->driver->set_operstate(hapd->drv_priv, 1);

Expand Down
17 changes: 17 additions & 0 deletions package/network/services/hostapd/src/wpa_supplicant/ucode.c
Original file line number Diff line number Diff line change
Expand Up @@ -136,6 +136,7 @@ static uc_value_t *
uc_wpas_add_iface(uc_vm_t *vm, size_t nargs)
{
uc_value_t *info = uc_fn_arg(0);
uc_value_t *driver = ucv_object_get(info, "driver", NULL);
uc_value_t *ifname = ucv_object_get(info, "iface", NULL);
uc_value_t *bridge = ucv_object_get(info, "bridge", NULL);
uc_value_t *config = ucv_object_get(info, "config", NULL);
Expand All @@ -154,6 +155,22 @@ uc_wpas_add_iface(uc_vm_t *vm, size_t nargs)
.ctrl_interface = ucv_string_get(ctrl),
};

if (driver) {
const char *drvname;
if (ucv_type(driver) != UC_STRING)
goto out;

iface.driver = NULL;
drvname = ucv_string_get(driver);
for (int i = 0; wpa_drivers[i]; i++) {
if (!strcmp(drvname, wpa_drivers[i]->name))
iface.driver = wpa_drivers[i]->name;
}

if (!iface.driver)
goto out;
}

if (!iface.ifname || !iface.confname)
goto out;

Expand Down
2 changes: 1 addition & 1 deletion package/system/procd/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=procd
PKG_RELEASE:=1
PKG_RELEASE:=2

PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
Expand Down
1 change: 1 addition & 0 deletions package/system/procd/files/hotplug.json
Original file line number Diff line number Diff line change
Expand Up @@ -11,6 +11,7 @@
[ "eq", "DEVNAME", "null" ],
[
[ "makedev", "/dev/%DEVNAME%", "0666" ],
[ "exec", "/bin/ln", "-s", "/proc/self/fd", "/dev/fd" ],
[ "exec", "/bin/ln", "-s", "/proc/self/fd/0", "/dev/stdin" ],
[ "exec", "/bin/ln", "-s", "/proc/self/fd/1", "/dev/stdout" ],
[ "exec", "/bin/ln", "-s", "/proc/self/fd/2", "/dev/stderr" ],
Expand Down
1 change: 1 addition & 0 deletions target/linux/ipq40xx/base-files/etc/board.d/02_network
Original file line number Diff line number Diff line change
Expand Up @@ -108,6 +108,7 @@ ipq40xx_setup_interfaces()
zte,mf286d)
ucidef_set_interfaces_lan_wan "lan2 lan3 lan4" "wan"
;;
zte,mf287|\
zte,mf287plus|\
zte,mf287pro)
ucidef_set_interface_lan "lan1 lan2 lan3 lan4"
Expand Down
1 change: 1 addition & 0 deletions target/linux/ipq40xx/base-files/lib/upgrade/platform.sh
Original file line number Diff line number Diff line change
Expand Up @@ -27,6 +27,7 @@ EOF
;;
zte,mf18a |\
zte,mf286d |\
zte,mf287|\
zte,mf287plus |\
zte,mf287pro |\
zte,mf289f)
Expand Down
221 changes: 221 additions & 0 deletions target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-mf287.dts
Original file line number Diff line number Diff line change
@@ -0,0 +1,221 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
// Copyright (c) 2022, Pawel Dembicki <paweldembicki@gmail.com>.
// Copyright (c) 2022, Giammarco Marzano <stich86@gmail.com>.
// Copyright (c) 2023, Andreas Böhler <dev@aboehler.at>

#include "qcom-ipq4018-mf287_common.dtsi"

/ {
model = "ZTE MF287";
compatible = "zte,mf287";
};

&gpio_modem_reset {
gpios = <&tlmm 5 GPIO_ACTIVE_HIGH>;
};

&key_reset {
gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
};

&key_wps {
gpios = <&tlmm 2 GPIO_ACTIVE_LOW>;
};

&led_status {
gpios = <&tlmm 0 GPIO_ACTIVE_LOW>;
};

&blsp1_spi1 {
pinctrl-0 = <&spi_0_pins>;
pinctrl-names = "default";
status = "okay";
cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>,
<&tlmm 59 GPIO_ACTIVE_HIGH>,
<&tlmm 1 GPIO_ACTIVE_HIGH>;

flash@0 {
compatible = "jedec,spi-nor";
#address-cells = <1>;
#size-cells = <1>;
reg = <0>;
spi-max-frequency = <24000000>;

partitions {
compatible = "fixed-partitions";
#address-cells = <1>;
#size-cells = <1>;

partition@0 {
label = "0:SBL1";
reg = <0x0 0x40000>;
read-only;
};

partition@40000 {
label = "0:MIBIB";
reg = <0x40000 0x20000>;
read-only;
};

partition@60000 {
label = "0:QSEE";
reg = <0x60000 0x60000>;
read-only;
};

partition@c0000 {
label = "0:CDT";
reg = <0xc0000 0x10000>;
read-only;
};

partition@d0000 {
label = "0:DDRPARAMS";
reg = <0xd0000 0x10000>;
read-only;
};

partition@e0000 {
label = "0:APPSBLENV";
reg = <0xe0000 0x10000>;
read-only;
};

partition@f0000 {
label = "0:APPSBL";
reg = <0xf0000 0xc0000>;
read-only;
};

partition@1b0000 {
label = "0:reserved1";
reg = <0x1b0000 0x50000>;
read-only;
};
};
};

spi-nand@1 { /* flash@1 ? */
compatible = "spi-nand";
reg = <1>;
spi-max-frequency = <24000000>;

partitions {
compatible = "fixed-partitions";
#address-cells = <1>;
#size-cells = <1>;

partition@0 {
label = "fota-flag";
reg = <0x0 0x140000>;
read-only;
};

partition@140000 {
label = "ART";
reg = <0x140000 0x140000>;
read-only;
compatible = "nvmem-cells";
#address-cells = <1>;
#size-cells = <1>;

precal_art_1000: precal@1000 {
reg = <0x1000 0x2f20>;
};

precal_art_5000: precal@5000 {
reg = <0x5000 0x2f20>;
};
};

partition@280000 {
label = "mac";
reg = <0x280000 0x140000>;
read-only;
compatible = "nvmem-cells";
#address-cells = <1>;
#size-cells = <1>;

macaddr_mac_0: macaddr@0 {
reg = <0x0 0x6>;
};
};

partition@3c0000 {
label = "cfg-param";
reg = <0x3c0000 0x600000>;
read-only;
};

partition@9c0000 {
label = "oops";
reg = <0x9c0000 0x140000>;
};

partition@b00000 {
label = "web";
reg = <0xb00000 0x800000>;
};

partition@1300000 {
label = "rootfs";
reg = <0x1300000 0x2200000>;
};

partition@3500000 {
label = "data";
reg = <0x3500000 0x1900000>;
};

partition@4e00000 {
label = "fota";
reg = <0x4e00000 0x3200000>;
};
};
};

zigbee@2 {
#address-cells = <1>;
#size-cells = <0>;

compatible = "silabs,em3581";
reg = <2>;
spi-max-frequency = <12000000>;
};
};

&tlmm {
serial_pins: serial_pinmux {
mux {
pins = "gpio60", "gpio61";
function = "blsp_uart0";
bias-disable;
};
};

spi_0_pins: spi_0_pinmux {
pinmux {
function = "blsp_spi0";
pins = "gpio55", "gpio56", "gpio57";
drive-strength = <12>;
bias-disable;
};

pinmux_cs {
function = "gpio";
pins = "gpio54", "gpio59", "gpio1";
drive-strength = <2>;
bias-disable;
output-high;
};
};
};

&wifi0 {
qcom,ath10k-calibration-variant = "zte,mf287";
};

&wifi1{
qcom,ath10k-calibration-variant = "zte,mf287";
};
Original file line number Diff line number Diff line change
Expand Up @@ -35,6 +35,16 @@
};
};

gpio_export {
compatible = "gpio-export";
#size-cells = <0>;

gpio_modem_reset: modem {
gpio-export,name = "modem-reset";
gpio-export,output = <0>;
};
};

keys {
compatible = "gpio-keys";

Expand Down Expand Up @@ -171,13 +181,11 @@
status = "okay";
nvmem-cell-names = "pre-calibration", "mac-address";
nvmem-cells = <&precal_art_1000>, <&macaddr_mac_0>;
qcom,ath10k-calibration-variant = "zte,mf287plus";
};

&wifi1 {
status = "okay";
nvmem-cell-names = "pre-calibration", "mac-address";
nvmem-cells = <&precal_art_5000>, <&macaddr_mac_0>;
mac-address-increment = <1>;
qcom,ath10k-calibration-variant = "zte,mf287plus";
};
Loading

0 comments on commit 838f25c

Please sign in to comment.