Skip to content

Commit

Permalink
Merge pull request #34 from openwrtdiy/openwrt-23.05
Browse files Browse the repository at this point in the history
Openwrt 23.05
  • Loading branch information
openwrtdiy authored Jul 20, 2023
2 parents 446d320 + b607cd3 commit a8c269b
Show file tree
Hide file tree
Showing 35 changed files with 170 additions and 210 deletions.
6 changes: 3 additions & 3 deletions package/libs/libbpf/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=libbpf
PKG_VERSION:=1.2.0
PKG_VERSION:=1.2.2
PKG_RELEASE:=1

PKG_SOURCE_URL:=https://github.com/libbpf/libbpf
PKG_MIRROR_HASH:=d20f5a226e5729c87c367f3fba61c44d5e13176ef12637d0e0b30629fa3ab0d6
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=fbd60dbff51c870f5e80a17c4f2fd639eb80af90
PKG_MIRROR_HASH:=80a80dfba71576e017b596fb28068e2a92de629e426f063e4b37314c8d576336
PKG_SOURCE_VERSION:=1728e3e4bef0e138ea95ffe62163eb9a6ac6fa32
PKG_ABI_VERSION:=$(firstword $(subst .,$(space),$(PKG_VERSION)))

PKG_MAINTAINER:=Tony Ambardar <itugrok@yahoo.com>
Expand Down
6 changes: 3 additions & 3 deletions package/libs/libnftnl/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=libnftnl
PKG_CPE_ID:=cpe:/a:netfilter:libnftnl
PKG_VERSION:=1.2.5
PKG_RELEASE:=2
PKG_VERSION:=1.2.6
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://netfilter.org/projects/$(PKG_NAME)/files
PKG_HASH:=966de0a8120c8a53db859889749368bfb2cba0c4f0b4c1a30d264eccc45f1226
PKG_HASH:=ceeaea2cd92147da19f13a35a7f1a4bc2767ff897e838e4b479cf54b59c777f4

PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
PKG_LICENSE:=GPL-2.0-or-later
Expand Down
6 changes: 3 additions & 3 deletions package/network/services/hostapd/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -9,9 +9,9 @@ PKG_RELEASE:=1.2

PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
PKG_SOURCE_DATE:=2023-03-29
PKG_SOURCE_VERSION:=bb945b98fefc64887dffb40773a19d77585cee42
PKG_MIRROR_HASH:=1da8a39c7c81ce257994874402a86d00080a6145b5eb5c5fc44b2fae1853fe8d
PKG_SOURCE_DATE:=2023-06-22
PKG_SOURCE_VERSION:=599d00be9de2846c6ea18c1487d8329522ade22b
PKG_MIRROR_HASH:=828810c558ea181e45ed0c8b940f5c41e55775e2979a15aed8cf0ab17dd7723c

PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=BSD-3-Clause
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ Signed-off-by: Peter Oh <peter.oh@bowerswilkins.com>

--- a/wpa_supplicant/wpa_supplicant.c
+++ b/wpa_supplicant/wpa_supplicant.c
@@ -2621,7 +2621,7 @@ static int drv_supports_vht(struct wpa_s
@@ -2638,7 +2638,7 @@ static int drv_supports_vht(struct wpa_s
}


Expand All @@ -23,7 +23,7 @@ Signed-off-by: Peter Oh <peter.oh@bowerswilkins.com>
{
int i;

@@ -2630,7 +2630,10 @@ static bool ibss_mesh_is_80mhz_avail(int
@@ -2647,7 +2647,10 @@ static bool ibss_mesh_is_80mhz_avail(int

chan = hw_get_channel_chan(mode, i, NULL);
if (!chan ||
Expand All @@ -35,7 +35,7 @@ Signed-off-by: Peter Oh <peter.oh@bowerswilkins.com>
return false;
}

@@ -2757,7 +2760,7 @@ static void ibss_mesh_select_40mhz(struc
@@ -2774,7 +2777,7 @@ static void ibss_mesh_select_40mhz(struc
const struct wpa_ssid *ssid,
struct hostapd_hw_modes *mode,
struct hostapd_freq_params *freq,
Expand All @@ -44,7 +44,7 @@ Signed-off-by: Peter Oh <peter.oh@bowerswilkins.com>
int chan_idx;
struct hostapd_channel_data *pri_chan = NULL, *sec_chan = NULL;
int i, res;
@@ -2781,8 +2784,11 @@ static void ibss_mesh_select_40mhz(struc
@@ -2798,8 +2801,11 @@ static void ibss_mesh_select_40mhz(struc
return;

/* Check primary channel flags */
Expand All @@ -57,7 +57,7 @@ Signed-off-by: Peter Oh <peter.oh@bowerswilkins.com>

#ifdef CONFIG_HT_OVERRIDES
if (ssid->disable_ht40)
@@ -2808,8 +2814,11 @@ static void ibss_mesh_select_40mhz(struc
@@ -2825,8 +2831,11 @@ static void ibss_mesh_select_40mhz(struc
return;

/* Check secondary channel flags */
Expand All @@ -70,7 +70,7 @@ Signed-off-by: Peter Oh <peter.oh@bowerswilkins.com>

if (ht40 == -1) {
if (!(pri_chan->flag & HOSTAPD_CHAN_HT40MINUS))
@@ -2863,7 +2872,7 @@ static bool ibss_mesh_select_80_160mhz(s
@@ -2880,7 +2889,7 @@ static bool ibss_mesh_select_80_160mhz(s
const struct wpa_ssid *ssid,
struct hostapd_hw_modes *mode,
struct hostapd_freq_params *freq,
Expand All @@ -79,7 +79,7 @@ Signed-off-by: Peter Oh <peter.oh@bowerswilkins.com>
static const int bw80[] = {
5180, 5260, 5500, 5580, 5660, 5745, 5825,
5955, 6035, 6115, 6195, 6275, 6355, 6435,
@@ -2908,7 +2917,7 @@ static bool ibss_mesh_select_80_160mhz(s
@@ -2925,7 +2934,7 @@ static bool ibss_mesh_select_80_160mhz(s
goto skip_80mhz;

/* Use 40 MHz if channel not usable */
Expand All @@ -88,7 +88,7 @@ Signed-off-by: Peter Oh <peter.oh@bowerswilkins.com>
goto skip_80mhz;

chwidth = CONF_OPER_CHWIDTH_80MHZ;
@@ -2922,7 +2931,7 @@ static bool ibss_mesh_select_80_160mhz(s
@@ -2939,7 +2948,7 @@ static bool ibss_mesh_select_80_160mhz(s
if ((mode->he_capab[ieee80211_mode].phy_cap[
HE_PHYCAP_CHANNEL_WIDTH_SET_IDX] &
HE_PHYCAP_CHANNEL_WIDTH_SET_160MHZ_IN_5G) && is_6ghz &&
Expand All @@ -97,7 +97,7 @@ Signed-off-by: Peter Oh <peter.oh@bowerswilkins.com>
for (j = 0; j < ARRAY_SIZE(bw160); j++) {
if (freq->freq == bw160[j]) {
chwidth = CONF_OPER_CHWIDTH_160MHZ;
@@ -2950,10 +2959,12 @@ static bool ibss_mesh_select_80_160mhz(s
@@ -2967,10 +2976,12 @@ static bool ibss_mesh_select_80_160mhz(s
if (!chan)
continue;

Expand All @@ -113,15 +113,15 @@ Signed-off-by: Peter Oh <peter.oh@bowerswilkins.com>

/* Found a suitable second segment for 80+80 */
chwidth = CONF_OPER_CHWIDTH_80P80MHZ;
@@ -3008,6 +3019,7 @@ void ibss_mesh_setup_freq(struct wpa_sup
@@ -3025,6 +3036,7 @@ void ibss_mesh_setup_freq(struct wpa_sup
int i, obss_scan = 1;
u8 channel;
bool is_6ghz;
+ bool dfs_enabled = wpa_s->conf->country[0] && (wpa_s->drv_flags & WPA_DRIVER_FLAGS_RADAR);

freq->freq = ssid->frequency;

@@ -3053,9 +3065,9 @@ void ibss_mesh_setup_freq(struct wpa_sup
@@ -3070,9 +3082,9 @@ void ibss_mesh_setup_freq(struct wpa_sup
freq->channel = channel;
/* Setup higher BW only for 5 GHz */
if (mode->mode == HOSTAPD_MODE_IEEE80211A) {
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -68,7 +68,7 @@ Signed-off-by: Markus Theil <markus.theil@tu-ilmenau.de>
if (!chan) {
--- a/src/drivers/driver_nl80211.c
+++ b/src/drivers/driver_nl80211.c
@@ -10739,6 +10739,10 @@ static int nl80211_switch_channel(void *
@@ -10977,6 +10977,10 @@ static int nl80211_switch_channel(void *
if (ret)
goto error;

Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/src/ap/ieee802_11.c
+++ b/src/ap/ieee802_11.c
@@ -4168,6 +4168,13 @@ static int add_associated_sta(struct hos
@@ -4601,6 +4601,13 @@ static int add_associated_sta(struct hos
* drivers to accept the STA parameter configuration. Since this is
* after a new FT-over-DS exchange, a new TK has been derived, so key
* reinstallation is not a concern for this case.
Expand All @@ -14,7 +14,7 @@
*/
wpa_printf(MSG_DEBUG, "Add associated STA " MACSTR
" (added_unassoc=%d auth_alg=%u ft_over_ds=%u reassoc=%d authorized=%d ft_tk=%d fils_tk=%d)",
@@ -4181,7 +4188,8 @@ static int add_associated_sta(struct hos
@@ -4614,7 +4621,8 @@ static int add_associated_sta(struct hos
(!(sta->flags & WLAN_STA_AUTHORIZED) ||
(reassoc && sta->ft_over_ds && sta->auth_alg == WLAN_AUTH_FT) ||
(!wpa_auth_sta_ft_tk_already_set(sta->wpa_sm) &&
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>

--- a/src/ap/hostapd.c
+++ b/src/ap/hostapd.c
@@ -3562,7 +3562,7 @@ static int hostapd_change_config_freq(st
@@ -3764,7 +3764,7 @@ static int hostapd_change_config_freq(st
struct hostapd_freq_params *old_params)
{
int channel;
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -20,7 +20,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#include <linux/rtnetlink.h>
#include <netpacket/packet.h>
#include <linux/errqueue.h>
@@ -5590,26 +5587,29 @@ fail:
@@ -5783,26 +5780,29 @@ fail:

static void rtnl_neigh_delete_fdb_entry(struct i802_bss *bss, const u8 *addr)
{
Expand Down Expand Up @@ -64,7 +64,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (err < 0) {
wpa_printf(MSG_DEBUG, "nl80211: bridge FDB entry delete for "
MACSTR " ifindex=%d failed: %s", MAC2STR(addr),
@@ -5619,9 +5619,8 @@ static void rtnl_neigh_delete_fdb_entry(
@@ -5812,9 +5812,8 @@ static void rtnl_neigh_delete_fdb_entry(
MACSTR, MAC2STR(addr));
}

Expand All @@ -76,23 +76,23 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
}


@@ -8275,7 +8274,6 @@ static void *i802_init(struct hostapd_da
@@ -8492,7 +8491,6 @@ static void *i802_init(struct hostapd_da
(params->num_bridge == 0 || !params->bridge[0]))
add_ifidx(drv, br_ifindex, drv->ifindex);

-#ifdef CONFIG_LIBNL3_ROUTE
if (bss->added_if_into_bridge || bss->already_in_bridge) {
int err;

@@ -8292,7 +8290,6 @@ static void *i802_init(struct hostapd_da
@@ -8509,7 +8507,6 @@ static void *i802_init(struct hostapd_da
goto failed;
}
}
-#endif /* CONFIG_LIBNL3_ROUTE */

if (drv->capa.flags2 & WPA_DRIVER_FLAGS2_CONTROL_PORT_RX) {
wpa_printf(MSG_DEBUG,
@@ -11605,13 +11602,14 @@ static int wpa_driver_br_add_ip_neigh(vo
@@ -11843,13 +11840,14 @@ static int wpa_driver_br_add_ip_neigh(vo
const u8 *ipaddr, int prefixlen,
const u8 *addr)
{
Expand All @@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
int res;

if (!ipaddr || prefixlen == 0 || !addr)
@@ -11630,85 +11628,66 @@ static int wpa_driver_br_add_ip_neigh(vo
@@ -11868,85 +11866,66 @@ static int wpa_driver_br_add_ip_neigh(vo
}

if (version == 4) {
Expand Down Expand Up @@ -220,7 +220,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
addrsize = 16;
} else {
return -EINVAL;
@@ -11726,41 +11705,30 @@ static int wpa_driver_br_delete_ip_neigh
@@ -11964,41 +11943,30 @@ static int wpa_driver_br_delete_ip_neigh
return -1;
}

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>

--- a/src/ap/ieee802_11.c
+++ b/src/ap/ieee802_11.c
@@ -2948,15 +2948,6 @@ static void handle_auth(struct hostapd_d
@@ -3012,15 +3012,6 @@ static void handle_auth(struct hostapd_d
seq_ctrl);
return;
}
Expand All @@ -25,7 +25,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
- sta->plink_state == PLINK_BLOCKED) {
- wpa_printf(MSG_DEBUG, "Mesh peer " MACSTR
- " is blocked - drop Authentication frame",
- MAC2STR(mgmt->sa));
- MAC2STR(sa));
- return;
- }
-#endif /* CONFIG_MESH */
Expand Down

This file was deleted.

Loading

0 comments on commit a8c269b

Please sign in to comment.