-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
820 changed files
with
228,678 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
*.exe | ||
*.exe.stackdump | ||
*.gcda | ||
*.gcno | ||
*.gcov | ||
*.la | ||
*.lo | ||
*.log | ||
*.o | ||
*.patch | ||
*.trs | ||
*~ | ||
.deps | ||
.libs | ||
configure | ||
compile | ||
depcomp | ||
missing | ||
Makefile.in | ||
Makefile | ||
/aclocal.m4 | ||
/autom4te.cache | ||
/config.h | ||
/config.h.in | ||
/config.guess | ||
/config.log | ||
/config.status | ||
/config.sub | ||
/install-sh | ||
/libtool | ||
/libtpms.pc | ||
/libtpms-*.tar.gz | ||
/ltmain.sh | ||
/stamp-h1 | ||
/test-driver | ||
/dist/libtpms.spec | ||
/include/libtpms/tpm_library.h | ||
/m4/* | ||
/tests/base64decode | ||
/tests/corpus-execute-command/ | ||
/tests/fuzz | ||
/tests/freebl_sha1flattensize | ||
/tests/nvram_offsets | ||
/tests/tpm2_createprimary | ||
/tests/tpm2_pcr_read | ||
/tests/tpm2_selftest | ||
/debian/*debhelper* | ||
/debian/*substvars | ||
/debian/files | ||
/debian/libtpms | ||
/debian/libtpms-dev | ||
/debian/tmp |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,90 @@ | ||
language: c | ||
dist: trusty | ||
env: | ||
global: | ||
secure: THraWTkpyL+b3lcnLenhXR6sxphcJS23MoUP36PT9VYhgZRI2YjO1w2h4V0uwzovbGJDU4Tc88Yxn8kL4RSgwy9cIcJcTOAorbePVRd+UFVU0nUjhwYLCKYBTLVLo7lYc0FHTgsdsba65X6keuSlAdegzCRbTvcwNqX9nanSRGI1CvYcwx22Iu5eOdJvMjwIuFOuECs7hVFrGS2rvGoyzqGNMT4A8shXOBZM/pwklRFS1oS/L1g45y3OP27yqINjtfC7wXRGsR8ItH7LAaQ+yCzNg3QzSd/3H3niEC5grcEMS23YugFUkGpqSca8SGJmkK2LFaBctpZS1P75lA/47Bxbh/byu85TUE6wZ+VPm520NkiYtBB+oxIbq1mYv+hhKuxPf5OqzdwLXVO7EAfzO57VkUqQfumWIZqV0WqCU3SdpRk+CUCCURR4P0ww+w6hQx6PzK21+d9tLtqMqdRwuricdyeLvxboWQXXl36fPf4ifmi0AZ6ILaV/LUQu24Di56RG4hO+/Pv/Qqxa8rJLpqJa0PtsYIiBNeVYLH/ZYIlS8saBedMIJ9dqh1dvBw/Jql8EZCOWif6UjYzQFgZAOZQqH9VAp1WVwQxQRo+Sq7dy+MtRKT2GEcNrdfYcL6qucBAQY00vQQBfl+FOnEzIAUImt4tbitnYTxmNx8N+QZU= | ||
addons: | ||
apt: | ||
packages: | ||
- automake | ||
- autoconf | ||
- libtool | ||
- libssl-dev | ||
- sed | ||
- make | ||
- gawk | ||
- sed | ||
- bash | ||
- dh-exec | ||
- libseccomp-dev | ||
coverity_scan: | ||
project: | ||
name: libtpms | ||
description: Build submitted via Travis CI | ||
notification_email: stefanb@linux.vnet.ibm.com | ||
build_command_prepend: "./autogen.sh --with-openssl --with-tpm2; make clean" | ||
build_command: make -j$(nproc) | ||
branch_pattern: coverity_scan | ||
script: | ||
- ./autogen.sh ${CONFIG} | ||
- make -j$(${NPROC}) ${TARGET} | ||
after_failure: | ||
- for f in tests/*.log; do echo ">>>>>>> $f <<<<<<<"; tail -n 50 $f; done | ||
before_install: | ||
- test $TRAVIS_BRANCH != coverity_scan -o ${TRAVIS_JOB_NUMBER##*.} = 1 || exit 0 | ||
matrix: | ||
include: | ||
- env: CONFIG="--with-openssl --prefix=/usr --with-tpm2" "TARGET=distcheck" | ||
NPROC="nproc" | ||
- env: CONFIG="--with-openssl --prefix=/usr --with-tpm2 --enable-test-coverage" | ||
TARGET="install" NPROC="nproc" | ||
dist: bionic | ||
before_script: | ||
- sudo pip install cpp-coveralls | ||
script: | ||
./autogen.sh ${CONFIG} && | ||
sudo make -j$(nproc) ${TARGET} && | ||
sudo make -j$(nproc) check && | ||
git clone https://github.com/stefanberger/swtpm.git && | ||
pushd swtpm && | ||
sudo rm -rf /dev/tpm* && | ||
sudo apt -y install devscripts equivs python3-twisted expect | ||
libtasn1-dev socat findutils gnutls-dev gnutls-bin tss2 | ||
python3-setuptools python3-cryptography python3-pip && | ||
pip3 install --upgrade pip && | ||
pip3 install --upgrade wheel && | ||
pip3 install --upgrade cryptography && | ||
./autogen.sh --with-gnutls --prefix=/usr && | ||
export SWTPM_TEST_EXPENSIVE=1 SWTPM_TEST_IBMTSS2=1 && | ||
sudo make -j$(nproc) check && | ||
popd | ||
after_success: | ||
uidgid="$(id -nu):$(id -ng)" && | ||
sudo chown -R ${uidgid} ./ && | ||
cpp-coveralls -b src -e tests -e swtpm --gcov-options '\-lp' | ||
- env: CONFIG="--with-openssl --prefix=/usr --with-tpm2 --enable-test-coverage --disable-use-openssl-functions" | ||
TARGET="install" NPROC="nproc" | ||
dist: bionic | ||
script: | ||
./autogen.sh ${CONFIG} && | ||
sudo make -j$(nproc) ${TARGET} && | ||
sudo make -j$(nproc) check && | ||
git clone https://github.com/stefanberger/swtpm.git && | ||
pushd swtpm && | ||
sudo rm -rf /dev/tpm* && | ||
sudo apt -y install devscripts equivs python3-twisted expect | ||
libtasn1-dev socat findutils gnutls-dev gnutls-bin tss2 | ||
python3-setuptools python3-cryptography python3-pip && | ||
pip3 install --upgrade pip && | ||
pip3 install --upgrade wheel && | ||
pip3 install --upgrade cryptography && | ||
./autogen.sh --with-gnutls --prefix=/usr && | ||
export SWTPM_TEST_EXPENSIVE=1 SWTPM_TEST_IBMTSS2=1 && | ||
sudo make -j$(nproc) check && | ||
popd | ||
- env: CONFIG="--with-openssl --prefix=/usr --with-tpm2" "TARGET=check" | ||
NPROC="sysctl -n hw.ncpu" CFLAGS="-I/usr/local/opt/openssl/include" | ||
LDFLAGS="-L/usr/local/opt/openssl/lib" | ||
# 'distcheck' results in duplicate symbol errors | ||
os: osx | ||
compiler: clang |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,79 @@ | ||
CHANGES - changes for libtpms | ||
|
||
version 0.7.7 | ||
- CryptSym: fix AES output IV | ||
A CVE has been filed for this bugfix. Unfortunately multi-step encrypted | ||
data won't decrypt anymore but are now compatible with other TPM 2 devices. | ||
|
||
version 0.7.6 | ||
- tpm2: Fix public key context save due to ANY_OBJECT_Marshal usage | ||
This fixes a suspend/resume problem when public keys are | ||
loaded | ||
- tpm2: Address some Coverity issues (false positives) | ||
- tpm1.2: Backported ASAN/UBSAN related fixes | ||
|
||
version 0.7.5 | ||
- Note: The TPM 2 implementation returns 2048 bit keys with ~1984 bit | ||
strength due to a bug in the TPM 2 key creation algo that cannot | ||
easily be fixed. The bug is in RsaAjustPrimeCandidate, which is | ||
called before the prime number check. | ||
- tpm2: Return properly sized array for b parameter for NIST P521 (HLK) | ||
- tpm2: Addressed issues detected by UBSAN | ||
- tpm2: Addressed issues detected by cppcheck (false positives) | ||
|
||
version 0.7.4 | ||
- Addressed potential constant-time related issues in TPM 1.2 and TPM 2 code | ||
TPM 1.2: RSA decryption | ||
TPM 2: EcSchnorr and EcSM2 signatures; Ecsda is handled by OpenSSL | ||
- Fixed some compilation issues | ||
|
||
version 0.7.3 | ||
- Fixed the set of PCRs belonging to the TCB group. This affects the | ||
pcrUpdateCounter in TPM2_Pcrread() responses, thus needs latest `swtpm` | ||
(master, stable branches) for test cases to succeed there. | ||
|
||
version 0.7.2 | ||
- Fix output buffer parameter and size for RSA decryption that could cause | ||
stack corruption under certain circumstances | ||
- Set the RSA PSS salt length to the digest length rathern than max. possible | ||
- Fixes to symmetric decrytion related to input size check, | ||
defer padding to the user [EVP_CIPHER_CTX_set_padding(ctx, 0)] and | ||
to always use a temporary malloc'ed buffer for decryption | ||
|
||
version 0.7.1 | ||
- tpm2: Fix TDES key creation by adding missing un-/marshalling functions | ||
- tpm2: Fix a bug in CheckAuthSession | ||
- compilation fixes for TPM 1.2 & TPM 2 and various architectures and | ||
gcc versions | ||
- Fix support for NIST curves P{192,224,521} and SM2 P256 and BN P648 | ||
that would not work; | ||
- Runtime filter elliptic curves (that OpenSSL does not support) and do | ||
not advertise those curves as capabilities | ||
- Removed unnecessary space in MANUFACTURER "IBM " -> "IBM" | ||
|
||
version 0.7.0 | ||
- use OpenSSL crypto for AES, TDES, EC, and RSA operations when possible | ||
|
||
version 0.6.0 | ||
- added TPM 2 support (revision 150) | ||
|
||
- New API calls: | ||
- TPMLIB_CancelCommand | ||
- TPMLIB_ChooseTPMVersion | ||
- TPMLIB_SetDebugFD | ||
- TPMLIB_SetDebugLevel | ||
- TPMLIB_SetDebugPrefix | ||
- TPMLIB_SetBufferSize | ||
- TPMLIB_ValidateState | ||
- TPMLIB_SetState | ||
- TPMLIB_GetState | ||
|
||
version 0.5.1 | ||
first public release | ||
|
||
- release 7 increased NVRAM area for being able to store more data in | ||
the TPM's NVRAM areas, i.e., X.509 certificates | ||
|
||
- release 9 added two more APIs: | ||
- TPM_Free | ||
- TPMLIB_DecodeBlob |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
The libtpms code was originally written by Kenneth Goldman | ||
<kgoldman@us.ibm.com>. | ||
|
||
The code has since been modified by Stefan Berger | ||
<stefanb@us.ibm.com>. | ||
|
||
Other contributors: | ||
Corey Bryant <coreyb@linux.vnet.ibm.com> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
Developer's Certificate of Origin 1.1 | ||
|
||
By making a contribution to this project, I certify that: | ||
|
||
(a) The contribution was created in whole or in part by me and I | ||
have the right to submit it under the open source license | ||
indicated in the file; or | ||
|
||
(b) The contribution is based upon previous work that, to the best | ||
of my knowledge, is covered under an appropriate open source | ||
license and I have the right under that license to submit that | ||
work with modifications, whether created in whole or in part | ||
by me, under the same open source license (unless I am | ||
permitted to submit under a different license), as indicated | ||
in the file; or | ||
|
||
(c) The contribution was provided directly to me by some other | ||
person who certified (a), (b) or (c) and I have not modified | ||
it. | ||
|
||
(d) I understand and agree that this project and the contribution | ||
are public and that a record of the contribution (including all | ||
personal information I submit with it, including my sign-off) is | ||
maintained indefinitely and may be redistributed consistent with | ||
this project or the open source license(s) involved. |
Oops, something went wrong.